Strict Standards: Non-static method CodeColorerLoader::Enable() should not be called statically in /home/k6000169/public_html/wp-content/plugins/codecolorer/codecolorer.php on line 254
Xcode | Programador freelance argentina

xcode

No provisioned iOS devices are available with a compatible iOS version.

Si ocurre este problema al intentar hacer correr una aplicación desde xcode en el un terminal iOS es probable que se deba a lo siguiente.

Por defecto xcode 4 crea aplicaciones con soporte sólo para armv7. Si tu terminal tiene un procesador armv6 ahí está el problema.

Para solucionarlo hay que agregar armv6 a la lista de arquitecturas soportadas. Esto se hace agregando una nueva entrada en el archivo ProjectName-Info.plist

Could not instantiate class named NSLayoutConstraint

Por defecto cuando se crea un proyecto nuevo en xcode 4.5 cada XIB creado utiliza autolayout lo cual es una propiedad de iOS 6.

Entonces al correr el proyecto con una versión de iOS < 6 explota. Las posibles soluciones son:

  • O bien correr el proyecto con iOS >= 6.0
  • O bien modificar poner la propiedad autolayout de cada XIB a false.

Para poner la propiedad autolayout a false, seleccionar el XIB y en el File Inspector deseleccionarla.

GCC 4.2 is not compatible with the Mac OS X 10.4 SDK

Go in the XCode to

Project > Edit Project Settings > Base SDK

And select MAC OSX 10.6 😉